Report directory overflow

I am working on a project where I optimize 10 parameters using "OptimizerSetEngine("cmae");". When this runs It creates 14,500 directors and 170,000 files that took up 2 geg of space in the Amibroker "Report" directory. After running the optimization several times I filled my SSD disk and had a devil of a time deleting the files .

  1. Do I have some setting wrong? These file are not used after the completion of the optimization yet they are keep.
  2. Can I keep these files from being generated?
  3. If I can't keep the files from being generated is there a way to direct them to another disk so the my fast 250G SSD disk does not fill and lock my computer?

Those files are backtest report folders generated per each Optimization step.

You say that you do not need them so deactivate full report generation in optimization.

SetOption( "GenerateReport", 0);


SetOption( "GenerateReport", 2);

Following modes offered:

SetOption("GenerateReport", 0 ); // suppress generation of report
SetOption("GenerateReport", 1 ); // force generation of full report
SetOption("GenerateReport", 2 ); // only one-line report is generated (in results.rlst file) viewable as single line in Report Explorer

Also there is a setting in Backtest settings - Report which can be unchecked (if detailed report is unwanted).