Risk/Yield Map no longer displaying points

I copied the code from the Amibroker web site to create a Risk/Yield Map and it was working fine, but now when I go to look at the map the data points do not show up and I don't know what has changed. The map gets created with the Risk and Yield axis displaying, but the data points don't show up. Does anyone know why? Thanks.

Most likely one of the symbols has incorrect data (such as unadjusted split) and it causes standard deviation to be widely out of reasonable range. Run Tools->Database purify to find out.

Following your suggestion I had no success. So I tried creating a new database and downloading fresh data, but it did not solve the problem. Next I upgraded to the most recent version 6.4 (was previously using 6.3) and still no success. So now using version 6.4 with a newly created database and new watch list, but can only see one symbol sometimes.

I tried creating a new watch list with only the symbol SPY, and it showed up. But when I added other symbols like QQQ and IWM still only see SPY on the RISK/YIELD tab. If I remove the SPY symbol, nothing shows up.

Symbol filter is set to watch list 0 which contains: QQQ, IWM, SPY, TLT, and SPYD. Changing time periods from weekly to daily makes no difference. I'm using the RiskYield.afl code from the Formulas\Explorations folder.

I notice when SPY is included in the list prior to clicking on the RISK/YIELD tab there are values in the Risk and Yield columns, but not for the other symbols. This is probably the source of the problem, but don't know there is only data there for SPY. Other explorations show data for all symbols.

Any further ideas?

I now think my problem is deeper. Perhaps some setting in the Windows register entries. I don't know, but as an experiment I tried running the MAEMFECharts.afl exploration. The tabs get created, but when I click on any of the tabs it crashes Amibroker. I sent a report after a crash.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.