Simple exploration not giving result

Written a very small and simple afl for exploration.
when RSI crosses above 70 or crosses below 30, the exploration should return such stocks.

I am using a watchlist for input, I am able to plot a "SIGN" at those cross points. I am running the explorer for "1 Recent day" to get a cumulative list of stocks which cross above 70 or crosses below 30.
Here is the piece of code -

_SECTION_BEGIN("RSI15");
rs=RSI(15);
Plot(rs, "RS", coloryellow);

Plot(50," ",colorblue);
Plot(30," ",colorwhite);
Plot(70," ",colorred);
buy=Cross(rs,70);
Sell=Cross(30,rs);
PlotShapes(IIf(Buy, shapeDigit3, shapeNone),colorWhite, 0,70,yoffset=0,XShift=0);
PlotShapes(IIf(sell, shapeDigit4, shapeNone),coloryellow, 0,30,yoffset=0,XShift=0);

cond1=Buy OR sell;
AlertIf(cond1, "SOUND C:\\Windows\\Media\\Alarm10.wav", "Audio alert", 1);

Filter = cond1;
SetSortColumns(-2);
_SECTION_END();

Screenshot of one such stock crossing below 30 -
below%2030

Screenshot of Explorer window (1 Recent day), watchlist contents and no result is in below section-
Explor

You are checking on 3 minute Chart but what is the periodicity of Analysis window?

If it is Daily, then RSI(15) is for 15 days and everything on Daily that's what i'm sure it is.

When you are troubleshooting, you should start with more recent bars and also tell us what that is doing.

image

Thanks, I am drawing RSI in 3 mins timeframe, explorer also in 3 mins time frame. Everything is in 3 mins time frame. I am using "DAILY" only to get results (by selecting "1 Recent Day(s)") in the explorer.

I ran your AFL, I'm getting output so that's why I told you to use more bars to check.

It also depends on the number of symbols added in that watchlist.
In the Filter settings, does it show all the symbols that will be included ?

Yes, it shows the symbols in the filter setting.
filtersetting

if you are using drag-n-drop for chart, then make sure the same AFL file is being used for both.
Click Edit in AA window and verify both codes having same formula.

I'm repeating, why don't you paste snap with many days in the test. I wont be able to respond line by line hand holding.

I am confirming, it is the same formula which is being used.

This time I have run the explorer for "*All Symbols" and for date range.
Still no result.
noresult

I closed all and restarted. It is working now. Thanks. Pl ignore the earlier screenshot, the AFL was different.