SMTP server error

Amibroker does not send an alert email. It used to send without any problems, but now when I send a test message, this window pops up. Does anyone know what this is about?

Hello gawdar,

could it be possible you have one space between your user name and domain, so this address would be invalid ? ... if yes, please remove this space ...

Best regards,

1 Like

It actually looks like a space, but it is not a space.

Hello gawdar,

your provider seems to be online and is listening to port 465. I checked it via "telnet 465" and

You could confirm to:

  1. Your email account user/password is not expired
  2. Your email account is not disabled/blocked @provider, for example by hacker attack
  3. Your Windows PC does not block outbound communication for port 465 with local MS Defender Firewall or any 3rd party virus/firewall software bundle
  4. Verify/think about that nothing changed in MS Windows environment after you recognize that AB E-mail Alerts stop to work
  5. Your PC is not affected by a virus or another local software/service on your PC is using port 465

Best regards,

This is server error, not amibroker error and it is described in many places, use Google to find out what the error is (using error number)

One of results:

Mr. Tom
Thanks for the information on the error but I can't figure it out. It's hard, there will be no alerts.

I tried to send a test viath with firewall and antivirus disabled on two different computers with Windows 11 because I have no other system and everywhere the same error. Messages from interia from other programs go out and come in without any problem. As for the sender I set Google Mail it is unchanged also error. I don't know what happened.

Best regards,

You did not even click on the link I gave you. Click on that link and read what is written there.

Hello gawdar,

perhaps you find alternate solution here

or try to get support from direct.

They listen to port 587 (TLS) ... you could try this port instead of 465 (SSL). You can check this in cmd.

telnet 587

Also i found this hit to use "App password" you have to setup in your email account ...

Best regards,

Proszę mi wierzyć Panie Tomku, że kliknąłem ten link i spędziłem jakieś sześć godzin nad tym problemem, ale nie jestem programistą i nie za bardzo wiem, o co tam chodzi. Jakieś kody czy zmieniać jakieś pliki w systemie? Jakieś serwery? Czy one są w systemie?

You need to talk to - it is their server. Nobody on this forum controls Interia. Generally the error means that the server and client cannot perform "handshake", i.e. they are using different protocols/versions/etc. There is pretty much infinite number of combinations of what client and server may or may not support. Also ISPs change their config and things that once worked stop working, etc. I have enough headache from my own stuff. I cannot save the whole world.

Probably the easiest way is finding ISP that just works (try gmail or protonmail or yahoo or or anything else). Sending ISP does not need to be your destination email.

Hello gawdar,

I can confirm yahoo smtp mail is working correct over SSL port 465, I did not use this AB feature in the past ...

You have to setup an additional "App-Password" at your Yahoo user profile to use in AB Alerts, not use your user account password.

So if does respond with sslv3 error, they does not support ssl anymore or you must setup some "App-Password" to use with AB ...

Please contact helpdesk and ask them what they changed or what steps you have to do in your account profile to use smtp sslv3 ?

I am using Windows 11 23H2, 2024-01 patch ...

Best regards,


Hello Peter,
Thank you very much for the hint. I did as you said. I have two-step verification enabled on my other google account and generated a password for the app, which I entered in amibroker and it finally worked. Great.
Thank you and best regards.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.