Some Forex Quotes Empty in Realtime Quote Window but not in TWS

Hi guys! Here's my issue. Many of my realtime quotes for forex have data but several other don't. For example, EUR.CAD and EUR.USD. My database is Interactive Brokers. The problem quotes in the realtime window in Amibroker display properly in TWS. The problem symbols also have a problem of being stuck with a March 16, 2023 latest date in Exploration (probable same cause). I have TWS 10.19.2a. At the bottom of the Amibroker window, the message says "No historical data query for ticker id: 1501" which is for EUR.CAD. From the scant nine months of experience I have with Amibroker, I tried the following:
-Double-checking the symbol is correct
-Including the exchange and security type in the symbol and IDEALPRO instead of IDEAL
-Checking the database settings
-Using the latest IB plugin I could find (I have 2.11)
-Deleting a symbol from the database and readding it (EUR.CAD, now it's blank)
-Running exploration to refresh the symbols in the watchlist those tickers are in
-Backfilling long and short time periods for those symbols
-Checking the market data connections status in TWS (green across the board)
-Searching the forum with several keyword combinations for empty quotes, old data in exploration for some symbols, etc.
-Trying the CFD equivalent (instead of cash) for EUR.USD
-From a chart window, clicking on the symbol in the symbol list
-Looking at error messages in IB Controller. Anything related to data or connection is in the information only range (2000-2999)
-Other things I'm forgetting at the moment

By the way, I'm also not getting any realtime quotes on the four cryptos available in TWS either. Other thing of note is I had 5 list of 100 stocks each and they are all ok in the realtime quote window. I had to add the exchange and security to 3-4 of them but then they were ok.

Any help is appreciated. Thanks!

@JaseBond, FWIW, it works for me using EUR.CAD-IDEALPRO-CASH (using both the latest version of TWS, and the officially unsupported 9.81.3 (but recommended by @Tomasz).

@beppe Thanks, I installed 9.81.3 and I'm getting quotes for all FX now. It solves the problem I raised. I thought it would be the same problem for cryptos and it probably also is the version but 9.81.3 doesn't show cryptos even in TWS.

Yeah I did get the message 9.81.3 was desupported as of 2023-07-18. Anyway I'll keep using this one anyways since the problem with FX quotes came from 10.19.2a for me.

@JaseBond I just tried it with TWS 1019.2a and IB Plugin 2.11 as yours. It just works, I have no problem with the above symbols. Thus, I suspect it could be due to a TWS setting (specific to forex market data ?).


Good idea, thanks! Version 981.3 was giving me an error message related to Java so I tried 10.23.2a but the problem with FX is back. I'll revert back to 981.3 and try to fix the Java problem. I combed through the settings as you suggested and clicked one new setting but no change though.

So I went back to 981.3 after installing Java 8 but I'm getting the same error message as before. 981.3 gave me that error message after the first installation. I had rebooted, then it went away so I thought I had succeeded but it was back afterwards and it's back with this reinstall of 981.3. I'm not sure what do do next. I'm on Windows 10 64-bit if that helps. Anyone?


I wouldn't install Java if not necessary. TWS installation packages come with JREs, so you don't need to install a JVM. Actually, if you don't know need Java, remove all TWS, all JVMs, reboot and reinstall TWS. Note that you can have two TWS versions installed at the same time, simply rename desktop shortcuts not to confuse them.

Thanks. I uninstalled 10.23 I had on and uninstalled java and rebooted. I installed 10.19 I had from January to try but it gave me an error message when I tried to launch it. I uninstalled it and rebooted then installed the same 10.23 I had yesterday. I could launch. I'll be able to test some FX trades overnight but the original problem of missing quotes is still there. I will try 981.3 again tomorrow and report back. I appreciate the help!

It is safest to use the stable offline version of TWS rather than the 'latest' version for live trading: the latter is more likely to have bugs.

However, it's not the point. As mentioned previously, it works with both v981.3 and v1019.2a. Look for a solution elsewhere (config, data subscriptions, server locations, antivirus…).

Again: Current data plugin works fine with most recent TWS 10.23. I even tested it again today and was able to display all IDEALPRO data. No problem.

Thanks! I will look at those four things or anything else I can't find if it's not that. I tried 981.3 again in brand new directory (if that changes anything at all) but still same java error message. I just tried 10.23 latest offline and same problem so the issue must be elsewhere as you suggested. I'll report back on that as well.

Thanks for taking the time to check Tomasz, I appreciate it!

1 Like

Some random ideas:

  1. You might be exceeding 100 real time streaming symbols (The limits add. If for example you have 80 symbols in TWS itself, you would be able only to see 20 extra symbols in AB)

  2. Check View->Symbol Information and make sure that these problematic symbols are NOT marked as "Use only local database for this symbol"

  3. Try using TWS 10.23 (standalone) - I use this one

Also as @alligator said - you need only ONE Java installed on the system - I have got Java Version 8 Update 361 and it works fine with both TWS 10.23 and 981

Thanks guys. Here are what I tried based on your suggestions. Still no luck with FX (and crypto) realtime quotes.

I emptied all my realtime window lists and TWS realtime lists. I have 10.23 standalone.

The problematic symbols were not checked to use as local database only.

Disabled my antivirus and closed Amibroker and reopened it.

In the top right corner in TWS, the word Data is highlighted in yellow. When I click on that it I see all market data connections are green. A yellow messages says some market data requires additional subscription for API users. When I click on that, it sends me to the client portal but I see the fee is waived for both cryptos and IDEAL FX for TWS. I looked everywhere I can't find anything extra to add for API users. In the connection window, the More Info link sends me to the connectivity test which shows success across for all tests.

I looked in Global Configuration settings in TWS. I had entered a the Trusted IP address before but the "Allow connections from localhost only" box was not checked but it didn't change anything.

I opened TWS with my real account instead of demo.

I checked the database settings again and flushed the cache. I lowered the max number of symbols from 700 to 100. The other settings are the same as in the guide How to use AmiBroker with Interactive Brokers TWS.

Could anything in Windows Defender Firewall block this? I tried disabling (then enabling again) the inbound rules for TWS.

@alligator , by server locations did you mean the connectivity test?

IB does NOT support 700 symbols.
Why did you changed to 700 symbols in first place? Why did you change the defaults?

It is very important NOT TO CHANGE defaults unless you absolutely are super-uber-hacker and you know what you are doing.

My advice is to create A NEW DATABASE and leave all DEFAULT settings.


Thanks Tomasz. Not 100% certain here since I did this over two months ago but my main strategy was to take trades based on a scan of the full S&P 500. It was also to alternatively use the same strategy on over 100 FX pairs so I had six quote boosters and a total of 700 quotes. I was already having the issue with the FX quotes but since my realtime quotes were working for stocks, I parked the issue until recently. Trying to increase the max number of symbols in the Configure Interactive Brokers plugin Window was one of the things I tried.

Back to today, I just created a new IB DB but the problem persists. I left the default settings as you just pointed out. Thanks for all your help!


Please send broker.master and broker.workspace to support email.

I checked with files you sent.

I used most recent TWS version 10.23.2a
and IB plugin version 2.11
(see Tools->Plugins)

All data are displayed normally, absolutely no problems at all.

Hi guys. I'm still experiencing this issue. I reviewed the previous posts to see if I missed something but didn't find anything.

However, I have the same issued with EURGBP when I used IQFeed as a database:

Out of 40 symbols for FX with IQFeed, this is the only one I'm having an issue with. Not sure if it will help much but that's where I'm at. I tried the force backfill suggested in the troubleshooting guide and it solved another problem of not getting all my data but it didn't work for EURGBP. I kept the settings to default.

It shows properly using the SnapQuote tool from IQFeed:

Thanks everyone for your support.

You have a typo. You typed

There is no such currency as GPB ( it should be GBP)

1 Like