Trade arrows not showing

I have used amibroker on and off for 12 years. A consistent problem for me across all versions has been the "show trade arrows" right click option after a backtest does not always work. Sometimes it does, sometimes not. It seems to not work for large periods of time.

I primarily work on 1 minute charts.

I suspect I have changed my default chart in some way that is hiding arrows, but I do not know what it is.

I have "show trade arrows" enabled on the chart options.

In the past a complete uninstall reinstall has fixed it.

I am using Windows 10, Amibroker 6.30.0 x64.

1 Like

You mean, chartShowArrows flag of the SetChartOptions function right?

Is this is set to:
image ?
(Image Source: How to display arrows for trades generated in backtest)

Is it the color combination of your chart?


1 Like

Yes, "Show trading arrows" is set in the chart properties.
I also tried calling SetChartOptions with chartShowArrows but that did not work either.

I have a friend who has the same issues, so I thought its worth raising here to see if anyone had a solution.

Sometimes people do all kind of weird things and they don't tell that and guessing games begin. There is no problem with the program. All kind of troubles are user-generated. Without seeing your computer it How to ask a good question.

For example people turn off default columns. That won't work.

Show trade arrows feature requires:

  • Backtest Trade list (it won't work with "summary" or "detailed log")
  • All default columns must be present in their original place. Specifically symbol in first column and date time in second column. Everything other than that won't work
  • "Show trading arrows" must be set in chart properties
  • The chart that shows arrows must be properly scaled (it must have PRICE chart, not MACD chart for example)
  • Data between backtest and "show arrows" must not change (if your data source added new quotes the arrows would be removed)
  • For certain kind of arrows ("raw arrows" for example) you need actual Buy/Sell/Short/Cover statements - you won't see raw arrows for rotational backtest because it does not have raw signals

Here is a 40 sec video example of what is going on:

I got my trade arrows back! I closed my default chart, created a new blank chart and added the 'Price (all in one)' formula to it. Now I have trade arrows on this chart.

Not sure why my old one did not work, but at least I have them now.

Thanks to those who responded.

1 Like