User mistake, was AmiQuote Volume Data Downloaded from Yahoo Finance Seems Incorrect

Hi,

I'm using AmiQuote 3.27. When I download EOD quotes from Yahoo i'm getting incorrect data.

Stock: CEI
Quote duration: from 5/25/2014 to 1/6/2018
Date with incorrect volume seen: 2/11/2015

AmiQuote fetched more than 6 million shares for this day but if I look at TradingView or Think or Swim charts I would see the volume is 254K not in the millions of shares.

What is casing this to happen? I can't do any proper scans with incorrect volume being reported from AmiQuote.

Thanks!

Volume is not ‘reported by AmiQuote’ but downloaded directly as is from Yahoo public web site like any other web browser would do. For any data errors, you should go directly to YAHOO site as instructed in FAQ:

1 Like

Hey Tomasz,

I understand this is the case. However the volume data displayed in Amibroker is different than the public yahoo website.

Steps: Use AmiQuote to download yahoo historical data from the symbol ABIL for Nov 20 2018.
Look at the chart it will show 60800 volume. Now look at the volume data provided by yahoo to the public can be found at: https://finance.yahoo.com/quote/ABIL/history?p=ABIL

You'll notice the data in amibroker is almost double the actual amount reported by Yahoo on the public website I've verified in Think or Swim that Yahoo website has the right data but amibroker has the wrong data yet it's grabbing it also from yahoo...

Hey Tomasz,

I think i found a way for the data to be different. I think the application may be calculating daily volume based on minute bars and it's including premarket data.

Steps.

  1. Import intraday 1 minute data for symbol ABIL.
    Minute data can be found from: https://transfernow.net/300lp1z0wigv
  2. Import daily data using AmiQuote historical Yahoo
  3. look at the volume from https://finance.yahoo.com/quote/ABIL/history?p=ABIL for 2018-11-20

Expected Daily volume value for 2018-11-20:
Should be 31,100

Actual Daily volume value in Amibroker Volume chart for 2018-11-20:
60,800

No, you are mistaken.

Data downloaded by AmiQuote for November 20th, is 31100 as shown below (double click on downloaded data line to see the data).

test

Your mistake comes from the fact that you are importing SAME DATA twice for the very same day.
You are importing intraday data and EOD data into same database.

AmIBroker's daily volume is a SUM of ALL volume for trades during given day that you have database. And you imported it TWICE (trades as intraday and trades as daily). And this intraday data get ADDED to EOD data because you have imported a MIX
http://www.amibroker.com/kb/2006/03/19/how-does-the-daily-time-compression-work/

Normally, you should either have intraday data OR EOD data, not both, unless you work in mixed mode (below).

You can actually have A MIX of end-of-day data and intraday data BUT.... you have to specifically TELL AmiBroker that you are going to have both mixed and ask AmIBroker to SEPARATE them, in File->Database Settings->Intraday Settings

image

Users' Manual describes it clearly:
http://www.amibroker.com/guide/w_dbsettings.html

Quote from manual:

Allow mixed EOD/Intraday data - it allows to work with database that has a mixture of intraday and EOD data in one data file. If this is turned on then in intraday modes EOD bars are removed on-the-fly and in daily mode EOD bars are displayed instead of time compressed intraday or if there is no EOD bar for corresponding day then intraday bars are compressed as usual.

The manual is written not because I have hobby of writing (just the opposite I find writing manuals really boring task), but for users to read it.

3 Likes

Thanks!!!! Your suggestion fixed my problem.