Vertical selector line cannot be seen on first week of month in weekly chart

On my weekly chart display, the vertical selector line disappears when selecting the first weekly bar of every month. The vertical line can be seen on other bars. What settings should I use to display the vertical selector line on every bar?

I am using Amibroker v6.29.0

Tools>Preferences>Colors>Selector Line

I changed mine to orange bold.

Thanks. However, it is not the color causing the problem. I changed it and the problem remains. Besides selector line not showing, even the starting and ending vertical lines do not show.

I had the same issue but its been a long time since.
I'm sure it has something to do with inconsistent data, because I fixed by aligning the market time correctly.
Also changed data vendor during that time.

Can you check if your Mkt timing includes Pre and Post market and that data fills all the bars in a lower TF?

1 Like

My data is end-of-day.

I am using Reuters datalink end-of-day. I would expect their data to be world-class.

I discovered another characteristic of this strange behavior. This missing vertical selector line problem does not happen when I zoom out on the chart. It happens when I zoom in on the chart.

since when is the issue? Can you describe it in more details?

Is it out of the blue, since last few days etc? For all symbols or a few?

Any update/upgrade to AB etc, was it fine last month on same AB 6.29?

This issue has always been there. I have been ignoring it as it is not really that irritating. It seems to happen on all symbols that I open so far.

That's strange. I've never experienced anything similar. As @Chris25 suggested, I would start from changing some Selector Line's settings...

But maybe it has something to do with Vertical Gridlines settings. Try changing Primary and/or Secondary Gridlines Style/Color (or some other settings in Axes/Grids tab).


If it doesn't help, showing us a screenshot of this issue might be a good idea...


A couple of days but no response.

As @Milosz said, can you share a gif or recording?

Anyway, i'm just wondering, do you have two open charts, say daily and weekly linked by symbol?
and you're scrolling, say with left/right keys on the daily chart and observing the weekly chart on which the first week of each month is not drawn ?

I found the solution to my problem. Under preferences->Axes/Grid->Vertical Gridlines->Uncheck Primary

That's interesting that you found this solution a month after I suggested that your problem might have something to do with Vertical Gridlines settings in my reply above. I even took a screenshot for you...

But I understand that your solution has nothing to do with my reply and for this reason it was not even worth saying "thank you".

Have a nice day :woozy_face:


Hi Milosz,

I thank you very much for your reply. I did recall trying stuff after seeing your reply a month ago but they didn't work. Perhaps the fault lies with me (can't recall if I tried the solution) or maybe it has to do with the latest version of Amibroker released. No matter what, I should have at least the courtesy at that time to thank you for your effort in taking the screenshot. I neglected to thank you last night because when I posted the solution, it was about midnight over at my side and I wanted to sleep soon.

My solution definitely has something to do with your reply. You deserve all the credit! Undoubtedly so not only for this thread but numerous others where you took time to share your expert knowledge.

Have a nice day. :slight_smile:


No problem @thankyou18 - you are welcome :slight_smile:

1 Like

I seriously doubt that. Unchecking Primary grid lines is not good idea at all (obviously you lose grid lines).

I guess that you changed some default settings. Go to Tools->Preferences, "Colors" tab and make sure that Selector line: BOLD checkbox is turned ON.
This is required because single-pixel selector line drawn behind candles (and behind grid but above alternate background fill) so vertical selection line does NOT cover candles' wicks. If it was drawn on top you will see the line but NOT the candle.
That is why by default the vertical line is BOLD, so even if there are grid lines and candles drawn it is still visible behind. The other solution is to make primary grid line DOTTED (you can do so in preferences)

1 Like

Hi Tomasz,

Many thanks! Your solution of bolding the selector line is much better. It works for me.

1 Like

Bold selector line is the default setting so you must have changed it at some point on your own. And because no one (apart from you) knows what is your current custom setup I asked you to make a screenshot to help us find a solution to your problem (you didn't do that).

It seems obvious that if your selector line is one pixel width and it overlaps with a vertical gridline it might disappear.

Without the screenshot it took over a month, 5 users and 15 posts to solve this trivial case ...

Hi Milosz,

I wanted to take the screenshot but the problem was missing selector line. I thought it's not really meaningful to take screenshot of a missing selector line. It didn't occur to me to take a screenshot when selector line is present because that was when things are working. So, even if I had taken the screenshot with the missing selector line, it wouldn't have been helpful.

You guys have been most helpful. Great community. Thank you.

For me nothing worked but HEY I found a solution.

Right Click on the Chart -> Parameters -> Axes & Grid Tab -> Miscellaneous Section -> Vertical Quote Marker -> Switch it to Show instead of Hide.

I don't know why it was hidden but I'm experimenting a lot...

You have hidden it yourself, because by default it is shown