Which Market Data Subscriptions for streeming realtime futures quote

HI,
Some years ago a used streaming realtime quotes for US futures from IB. It works OK. Now, after a pause, I will use it again, but it do not worts any more. I use AB profesional 5.40.3 (the same as in time whten it works OK), win 10 64bit and TWS build 972.1p

Now, on futures, the IB plug-in make only backfill on first access, but not streaming quotes and not later other backfill. Connection status is green. Symbol name is e.g. "esz8-globex-fut". The chart is updated. When I make later other backfill, it happes nothing. only when I make reconnection of the pug-in, backfill load missing quotes, but the chart will still not been updated. It works (realtime quotes) on shares e.g. spy or forex , but futures not.
I am not sure if the problem is really wrong data subscription, because in TWS I can open a live chart with ES and it is OK. I thing, if there would be some problem with my version of AB, it would not work even with ticker spy.
My actuell data subscriptions are:
IDEAL FX
US and EU Bond Quotes
US Equity and Options Add-On Streaming Bundle
US Reg NMS Snapshot
US Securities Snapshot and Futures Value Bundle

Do I have wrong data or make I something other wrong?

Thank for your answers.
Jaroslav

Hi,

Do you get real time quotes for futures in TWS ?

Best regards,
Alexander

Hi,
yes, I see it.
realtime-quote-tws-2018-11-14
realtime-quote-AB-2018-11-14

Jaroslav

I try to install new (unregistred) version of AB, but the result is the same as with my old version. Forex and shares work OK, but futures not.
Jaroslav

I tried ESZ8-GLOBEX-FUT - it works ok.

I have following subscriptions:

  • AMEX (Network B/CTA)
  • CBOE Streaming Market Indexes
  • CBOT Real-Time
  • CFE Enhanced
  • CME Real-Time
  • NASDAQ (Network C/UTP)
  • NYMEX Real-Time
  • NYSE (Network A/CTA)
  • OPRA (US Options Exchanges)
  • US and EU Bond Quotes

Alexander

Hi,
you have a lot of data subscriptions.
I ask in IB support which additional data subscriptions do I need. The man on chat answered, that when I get backfill, so the data subscription should be OK an he ask me for tws log and then he answered, that problem ist, that i write the ticker in lower case, but it shoul be in upper case.
I renamed the symbols and now it works OK. But in the past it works in lower case too.