Windows requirements for running newest 64-bit versions

Starting from 6.22 BETA, 64-bit version of AmiBroker uses new compiler (VC2017) and since it uses so called “Universal C runtime” which is now OS system component it puts the following requirements for installed OS updates:

Requirements for Windows 7 64bit:

  • Windows 7 Service Pack 1 installed (KB976932)
  • Universal C runtime update installed (KB2999226)

Requirements for Windows 8, 8.1 64-bit

  • Universal C runtime update installed (KB2999226)

Requirements for Windows 10 64-bit:

  • None (all necessary updates are forced by Microsoft)