Yahoo Volume Data Issue

Hi I have been having a bit of trouble with my amiquote download these few days. Previously you have advised me to include $VOLFACTOR 1 which I have done it which it works.

However, the problem recently came back. I tried to auto-download again 3 years of data from amiquote, but still see the same issue. Finally, i tried to download it manually one by one, then the volume data recovers as normal for each ticker. So wondering if it's some problem with the auto-download? Thanks.

Screenshot 2021-08-12 074743

It has absolutely nothing to do with AmiBroker or AmiQuote.

AmiQuote is simple web browser that JUST downloads the data and does NOT modify them.

It is just that YAHOO FINANCE feeds you with rescaled volume because you happen to be connected at the moment to server that responds with bad data. That is load balancing that Yahoo uses. It is explained here: The majority of quotes update, but some don't - #11 by Tomasz

What you can only do is to: wait until Yahoo fixes problem ON THEIR END / reconnect / re-download.

By the way $VOLFACTOR 1 is the default (does not need to be specified).

Check your aqh.format file. It should look like this:

# AmiQuote historical quotes download format (.AQH extension)
# Revision 1.4 - changed the order of columns (due to July 22, 2017 Yahoo site change)
# Revision 1.3 - changed the order of columns (due to May 17, 2017 Yahoo site change)
# Revision 1.1 - removed $VOLFACTOR 0.01
# The format line below allows to get data adjusted for SPLITS
# to get data adjusted for SPLITS AND DIVIDENDS replace 'Skip' by 'AdjClose'
$FORMAT Date_DMY,Open,High,Low,Close,AdjClose,Volume
$GROUP 254
# the following switches are optional - please consult
# the read-me for description of those options

Well, I experience exactly the same thing here for the past few days.. (Singapore)

Temporary workaround is to use


Hi Tomasz,

I have changed to $VOLFACTOR 0.01 and unfortunately didn't resolve. what I observed is that when I do an auto mass download of all tickers from 1 Jan 2019 to now, I still see the volume issue. However, if i were to update it one by one manually, the volume gets corrected.

Let me show you a before (mass update) and after (one-by-one manual update) for ticker DRE. Anyway to solve this?


Re-read my previous (first) reply. It contains EVERYTHING about it. It is LOCAL YAHOO PROBLEM (i.e. you, personally, are connected to bad server).
And $VOLFACTOR 0.01 definitely works (if you add it in correct place (aqh.format)).
There is no difference between one symbol download and many symbols download. It works exactly the same. In fact "multiple" symbol downloads are just series of single symbol downloads.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.